ESXI打造最强家庭软路由系统ROS+LEDE+全能NAS方案(2018版)

玩了大半年的软路由和NAS、给大伙分享一下我用家庭NAS完整解决方案。ROS+LEDE+DSM黑群晖+Debian。我使用的实体机是芯盛美迷你主机。使用这个主机来实现的好处是

  1. 一台设备就实现了所有功能,不会占用地方。
  2. 省电。主机功耗在18W/小时,整体功耗大约在35W/小时左右(包含光猫,WIFI,玩客云,小爱同学)。
  3. 安静。主机采用铝板被动散热,所以整机非常安静。(夏天还是需要用个USB风扇辅助散热一下的)。
  4. 群晖和Linux上的应用基本都会有手机APP支持,可以在手机APP上操作,非常方便。
  5. 比起windows平台,要实现同样功能,使用Linux平台会在CPU等资源消耗方面低很多。

    下面简单说下分工

  • ROS-主路由的工作:VRRP+PCC多线负载、DHCP、端口映射、VPN服务器、花生壳DDNS。
  • LEDE-旁路由的工作:KMS微软激活、koolproxy广告过滤、美元服务、frpc内网穿透、阿里云DDNS等各种路由应用。
  • DSM黑群晖+debian的工作:数据存储、文件共享、PT下载、Docker、Emby、SVN版本控制、LNMP、手机终端数据同步等等。


首先,先上我们的主角的照片。
主角配置:

名称 配置
CPU I7-4600U
内存 8G DDR3L + 4G DDR3L
网卡 Realtek 8168 * 4(自带2个,MiniPCI扩展了2个)
硬盘 4T 2.5寸 HDD + 128G msata SSD + 1T msata SSD

接着上图K2P和玩客云:

上网络拓扑图:

Backup-PC上面装了5块硬盘,ROS每天凌晨4点自动网络唤醒Backup-PC,将当天数据做一个本地备份后关机。关键数据有4处备份。本地备份、玩客云、百度云、onedrive、以保证数据安全。这样做第一会比平时硬盘全开省电不少,第二比组RAID1硬盘的空间利用率更高。第三安全总不可能4个地方的数据同时坏吧!

安装需要的虚拟机

安装ESXI6.5

ESXI详细安装步骤点这里

安装ROS

ROS详细安装步骤点这里

安装LEDE

LEDE详细安装步骤点这里


配置虚拟机

配置ROS

先按下面的方法,把ROS配置好,让其可以正常上网。
ROS配置步骤点这里

  • ROS的DHCP配置

  • 选择LAN网卡

  • 网段设置,我用的31段。这个你可以自由设置。

  • 划重点,这里要设置成下面LEDE的IP地址。

  • 结束

配置LEDE

  • 开启LEDE虚拟机

  • 进入虚拟机LEDE控制台

  • 配置网卡

    在命令行输入
    1
    nano /etc/config/network


将网卡配置更改为下面的内容,然后按Ctrl+X保存退出。注意:IP和网关需要根据自己的网络来修改,

1
2
3
4
5
6
7
8
9
10
11
12
13
14
15
16
17
18
config interface 'loopback'
option ifname 'lo'
option proto 'static'
option ipaddr '127.0.0.1'
option netmask '255.0.0.0'

config globals 'globals'
option ula_prefix 'fdf1:53e1:6bd9::/48'

config interface 'lan'
option type 'bridge'
option proto 'static'
option ipaddr '192.168.31.40'
option netmask '255.255.255.0'
option ip6assign '60'
option ifname 'eth0'
option gateway '192.168.31.250'
option dns '223.5.5.5'

IP设置成跟ROS为同一网段,网关设置成ROS的IP地址 option ipaddr代表IP地址。option gateway 代表网关



输入下面的命令,重启LEDE网络

1
/etc/init.d/network restart


浏览器输入IP:192.168.31.40,访问LEDE
配置LAN

关闭DHCP服务器

更新软件中心及固件。


自此LEDE的配置就完成了。

KMS,广告过滤,美元。

  • KMS微软激活



    激活WINDOWS,首先安装vol大客户版windows和office,然后以管理员权限运行CMD.运行下面的命令
    1
    2
    3
    4
    5
    6
    7
    8
    9
    10
    11
    激活Windows
    cd C:\Windows\System32
    CSCRIPT /NOLOGO SLMGR.VBS /SKMS 192.168.31.1
    CSCRIPT /NOLOGO SLMGR.VBS /ATO
    CSCRIPT /NOLOGO SLMGR.VBS /XPR
    ---------------------------------------------
    激活Office2016(以64位为例子)
    cd C:\Program Files\Microsoft Office\Office16
    CSCRIPT OSPP.VBS /SETHST:192.168.31.1
    CSCRIPT OSPP.VBS /ACT
    CSCRIPT OSPP.VBS /DSTATUS

记住:192.168.31.1这个地址,要改成你自己的LEDE的IP。

  • koolproxy广告过滤



    开启第三方规则,我开这三个规则过滤视频广告是最优的。你们也可以自己试试。

  • 美元服务


    开启美元,输入自己的SS节点,然后添加。

    选择刚才添加的节点,提交.

    第一次开启美元,记得要更新一下规则.

本文标题:ESXI打造最强家庭软路由系统ROS+LEDE+全能NAS方案(2018版)

文章作者:Hank ZHU

发布时间:2018年08月10日 - 10:59

最后更新:2019年08月15日 - 15:50

原始链接:http://zealot.top/ESXI打造最强家庭软路由系统-ROS-LEDE-全能NAS.html

许可协议: 署名-非商业性使用-禁止演绎 4.0 国际

如需转载请注明文章出处,并保留原文链接及作者。感谢您尊重别人的劳动成果!


-------------本文结束 感谢您的阅读-------------
-------------如果觉得这篇文章不错,可以请作者喝杯咖啡!-------------