ROS 实现用花生壳做DDNS

ROS6.X以上版本,动态DDNS绑定方法。本人现在使用的6.46测试正常。

建立脚本

用winbox登陆ROS.在systemscript下,新建一个脚本。

输入脚本名字ddns,输入下面的代码:

1
2
3
4
5
6
7
8
9
local ipaddr
local server "http://ddns.oray.com"
local domain "输入你的域名"
local par "/ph/update?hostname=$domain&myip=$ipaddr"
local users "花生壳的用户名"
local paswd "花生壳的密码"
:set ipaddr [/ip address get [/ip address find interface=pppoe-out1] address]
:set ipaddr [:pick $ipaddr 0 ([len $ipaddr] -3)]
/tool fetch url=($server . $par) mode=http user=$users password=$paswd

备注:如果是多拔的同学,想要选择是用哪条线路的IP。可以在interface=pppoe-out1这里改成你想要的线路。

运行脚本

在script list中选择要执行的脚本点Run Script就运行了。

建立定时任务,每15分钟自动刷新DDNS

systemScheduler下,新建一个任务。
输入你的任务名,Interval是执行的时间(我设置的是每15分钟执行一次),最后在内容里输入:

1
/system script run ddns

大功告成!

-------------本文结束 感谢您的阅读-------------
-------------如果觉得这篇文章不错,可以请作者喝杯咖啡!-------------